Configuration of 11.1.2.2 Forms & Reports on Windows fails at the step 'OPMN starting report server component'

Configuration of 11.1.2.2 Forms & Reports on Windows fails at the step 'OPMN starting report server

APPLIES TO:

Oracle Fusion Middleware - Version 11.1.2.0.0 to 11.1.2.2.0 [Release Oracle11g]
Microsoft Windows x64 (64-bit) - Version: 2008 R2
Microsoft Windows x64 (64-bit) - OS Version: 7

SYMPTOMS

During the configuration of Reports Services in a 11.1.2.2 Forms & Reports Installation on Windows 2008 R2 64 bit machine, it fails at the step "Opmnctl startproc ias-component=RptSvr_xxxx_xxx". It gives the error, "Multicast:init java.net.SocketException: Unrecognized Windows Sockets error: 0: no Inet4Address associated with interface"

The following full error stack may be seen in rwserver_diagnostic.log :

[2015-01-14T11:55:09.103-05:00] [reports] [WARNING] [] [oracle.reports.server] [tid: 10] [ecid: 0000KfdNfjsFg4G6yzNa6G1Khdxe000001,0] Multicast:init java.net.SocketException: Unrecognized Windows Sockets error: 0: no Inet4Address associated with interface
[2015-01-14T11:55:09.103-05:00] [reports] [WARNING] [] [oracle.reports.server] [tid: 10] [ecid: 0000KfdNfjsFg4G6yzNa6G1Khdxe000001,0] Multicast:init java.net.SocketException: Unrecognized Windows Sockets error: 0: no Inet4Address associated with interface
[2015-01-14T12:00:06.891-05:00] [reports] [INCIDENT_ERROR] [REP-50002] [oracle.reports.server] [tid: 11] [ecid: 0000KfdOoknFg4G6yzNa6G1Khe2M000000,0:1:100000000] REP-50002 : The server is shutting down. [[
oracle.reports.RWException: IDL:oracle/reports/RWException:1.0
at oracle.reports.utility.Utility.newRWException(Utility.java:1053)
at oracle.reports.server.RWServer.stateCheck(RWServer.java:1567)
at oracle.reports.server.ConnectionImpl.callCheck(ConnectionImpl.java:2979)
at oracle.reports.server.ConnectionImpl.disconnect(ConnectionImpl.java:757)
at oracle.reports.server.ConnectionPOA._invoke(ConnectionPOA.java:309)
at com.sun.corba.se.impl.protocol.CorbaServerRequestDispatcherImpl.dispatchToServant(CorbaServerRequestDispatcherImpl.java:637)
at com.sun.corba.se.impl.protocol.CorbaServerRequestDispatcherImpl.dispatch(CorbaServerRequestDispatcherImpl.java:189)
at com.sun.corba.se.impl.protocol.CorbaMessageMediatorImpl.handleRequestRequest(CorbaMessageMediatorImpl.java:1682)
at com.sun.corba.se.impl.protocol.CorbaMessageMediatorImpl.handleRequest(CorbaMessageMediatorImpl.java:1540)
at com.sun.corba.se.impl.protocol.CorbaMessageMediatorImpl.handleInput(CorbaMessageMediatorImpl.java:922)
at com.sun.corba.se.impl.protocol.giopmsgheaders.RequestMessage_1_2.callback(RequestMessage_1_2.java:181)
at com.sun.corba.se.impl.protocol.CorbaMessageMediatorImpl.handleRequest(CorbaMessageMediatorImpl.java:694)
at com.sun.corba.se.impl.transport.SocketOrChannelConnectionImpl.dispatch(SocketOrChannelConnectionImpl.java:451)
at com.sun.corba.se.impl.transport.SocketOrChannelConnectionImpl.doWork(SocketOrChannelConnectionImpl.java:1213)
at com.sun.corba.se.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.performWork(ThreadPoolImpl.java:471)
at com.sun.corba.se.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.run(ThreadPoolImpl.java:500)


The following "WLS ManagedService is not up running" may be seen in console_RptSvr_xxxx_xxxx.log :

15/01/14 11:55:04 Start process
--------
WLS ManagedService is not up running. Fall back to use system properties for configuration.
OpmnIntegrator: Register Ping callback.
OpmnIntegrator: Shutdown ...
Stop process
--------

CHANGES

No changes done, its a fresh installation during which issues may be seen.

CAUSE

Settings in NIC card may not allow the installer to complete the configuration.
 

SOLUTION

1) Check with ipconfig /all there is an IPv4 address enabled and check if multicast is enabled too

c:\> ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : myhostname
Primary Dns Suffix . . . . . . . : mydomain.com
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : mydomain.com

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : es.oracle.com
Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Desktop Adapter
Physical Address. . . . . . . . . : 08-00-27-D7-CE-D2
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 10.0.2.15(Preferred) 
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Thursday, September 25, 2014 2:58:01 PM
Lease Expires . . . . . . . . . . : Saturday, January 24, 2015 12:09:40 PM
Default Gateway . . . . . . . . . : 10.0.2.2
DHCP Server . . . . . . . . . . . : 10.0.2.2
DNS Servers . . . . . . . . . . . : 10.0.2.3
NetBIOS over Tcpip. . . . . . . . : Enabled

If IPv4 is not enabled contact the network administrator to assign an IPv4 address.


2)  Check if multicast is enabled with the netsh interface ip show joins command:

C:\>netsh interface ip show joins

Interface 1: Loopback Pseudo-Interface 1

Scope References Last Address
---------- ---------- ---- ---------------------------------
0 1 Yes 239.255.255.250

Interface 14: Local Area Connection

Scope References Last Address
---------- ---------- ---- ---------------------------------
0 0 Yes 224.0.0.1
0 1 Yes 224.0.0.252
0 1 Yes 239.255.255.250

If you don't see any row corresponding to your network interface it means multicast is not enabled.  If multicast is not enabled contact the network administrator to enable it.

3) Once confirmed you have an IPv4 address and multicast enabled retry the configuration and confirm is working fine.

Return to Blog