REP-300: Oci_invalid_handle / REP-501 Reports Engine Crash

REP-300: Oci_invalid_handle / REP-501 Reports Engine Crash

Applies to

Oracle Reports Developer - Version 11.1.1.2.0 and later
Microsoft Windows Itanium (64-bit)
Microsoft Windows x64 (64-bit)
Linux x86-64

Symptoms

Sometimes a report job failed with the following error :REP-300/501.
The behavior is random when generating the reports.
The problem happens for reports started via forms/run_report_object or using "rwservlet"  with desformat PDF, destype cache or file.

After the first reports job has crashed, all following jobs of any kind return with error REP-501, so the engine cannot connect to the DB anymore till you restart the reports server or engLife is reached and the engine is restarted.

Possible error message is :

REP-300: OCI_INVALID_HANDLE. ==> select .....

Common possible errors that can be found in diagnostic log filess are : REP-300 : OCI_INVALID_HANDLE, REP-0501, and ORA-00002

Cause

This is caused by the following two bugs:

Bug:10100777 "Reports Engine Crash With Rep-501"
Bug:13327994 "REP-300 / REP-501 AFTER A WHILE OF USING REPORTS SERVER EVEN WITH PATCH 10100777"

Solution

 

As mentioned above, there are two bugs causing the same error, applying the fix for one of them may or may not solve the problem based on which bug is hit. To fix the problem completely, the fix for the two bugs should be applied together. The way to apply the patches differ slightly on version and platform.

1. For 11gR2 (11.1.2.X)

The fix of Bug:10100777 is already included in this version. So there is no need to apply the fix for this bug on 11gR2 (11.1.2.X) versions. It is only necessary to apply the fix Patch:13327994

2. For 11gR1 (11.1.1.X) MS Windows x64 (64-bit) Platforms

There are merge patches (one patch including both fixes) for MS Windws 64-bit platforms :

11.1.1.6 : The fix of Bug:10100777 is already included in this version. It is only necessary to apply the fix Patch:13327994

11.1.1.4 : Patch:13430483

11.1.1.3 : Patch:13604053

3. Other 11gR1 (11.1.1.X) Platforms

11.1.1.6 : The fix of Bug:10100777 is already included in this version. It is only necessary to apply the fix Patch:13327994

11.1.1.3 and 11.1.1.4 : It is necessary to download and apply two patches seperately for your version : Patch:10100777 and Patch:13327994

Apply the patch(es) following the instructions file (README.txt) associated.

Other known workaround is to set engLife=1 for the related Report Server (which may cause some performance degrade under some circumstances).

In case the problem persists, please raise a Service Request to contact Support and provide details why you think you are still affected by this problem. A testcase will be required in this condition.

Mis en ligne par Patrick Hamou le 2016:04:19 21:04:51

Return to Blog