FRM-41214 Troubleshooting guide, common causes and solutions

FRM-41214 Troubleshooting guide, common causes and solutions

Introduction

APPLIES TO:
Oracle Forms - Version 6.0.8.8.0 and later
Information in this document applies to any platform.
Checked for relevance on 21-Dec-2009

Symptoms

You are trying to integrate Reports in Forms code using RUN_REPORT_OBJECT.  At runtime, when calling a Report from Forms the following error is encountered:

FRM-41214: Unable to run report.

The current document provides an overview of the common causes that can generate this error and provides details on how to further troubleshoot it.

Cause

FRM-41214 indicates that an invalid parameter has been passed to the Report Server. Also, FRM-41214 means that Forms has been able to submit the report to the Reports server and therefore the communication between Forms and the Reports Server is fine.

TROUBLESHOOTING: 
This error occurs in the moment where Reports Server begins to process the request and more information about the exact cause of this error can be found, in fact, on the reports side and depending on the situation, the solution may need to be implemented on the Forms or Reports side.

Try the following to gather more information on the error:

  1. Immediately after the problem occurs with RRO, note if the job was submitted to the reports server: http://machine.domain:port/reports/rwservlet/showjobs?server=rep_server_name 
  2. Use the Queue Manager, for details see Note 1322799.1
  3. Enable reports tracing, to obtain the trace information one should perform the following steps: 
    1. Enable Reports Server tracing as described in Note 237301.1 
      Make sure that the following line exists in the Reports Server Configuration file (ORACLE_HOME/reports/conf/<Reports-server-name>.conf) before starting the Reports Server <trace traceOpts="trace_all"/> 
    2. Reproduce the problem by running the form and calling the report 
    3. Check the trace file generated, by default, in ORACLE_HOME/reports/logs/<Reports-Server-Name>/rwserver.trc

Common causes and solutions

The report mentioned in the REPORT parameter is not accessible 

In this case the following errors are displayed in the Reports Server trace:

REP-110: Unable to open file 'test.rdf'. 
REP-1070: Error while opening or saving a document.

Explanation: The Reports object contained within Forms is pointing to a report that does not exist or that cannot be accessed. 

Solution: In Forms "Object Navigator" go to the Reports node and open the properties for the "Report Object" executed from Forms. Double check the value specified for the "Filename" parameter and be sure that is pointing to an existing/accessible report.  If the "Filename" parameter does not contain an explicit path to the report, then ensure the report is located in a directory referenced by the REPORTS_PATH environment variable. 

Usage of DESTYPE=SCREEN or DESTYPE=PREVIEW 

In this case the following error is displayed in the Reports Server trace:

Exception 56092 (): No class defined for destination type screen or 
Exception 56092 (): No class defined for destination type preview

Explanation: SCREEN or PREVIEW are not valid values for DESTYPE parameter when using Reports Server. 

Solution: Use other values, different then SCREEN or PREVIEW, for the DESTYPE parameter. Valid options when using Reports Server are FILE, PRINTER, MAIL or CACHE. If the output needs to be shown in the browser then the correct usage is "DESTYPE=CACHE" For more details check Note 169619.1 FRM-41214 Error Using Run_Report_Object When Destype = Screen or Preview.

Wrong value data type passed as parameter or wrong width (length) of the parameter value

In this case the following errors may be displayed in the Reports Server trace:

REP-546: Value does not match mask 'DD-MON-RR'. 
ORA-01858: a non-numeric character was found where a numeric was expected 
REP-0091: Invalid value for parameter 'P_1'.  or
REP-546: Invalid value for parameter 'P_1'.

Explanation: These errors may be encountered when, for example, the Report Parameter has the "Datatype" Numeric and Forms passes a Character value: "abc". In this case the Reports Server cannot process the value passed therefore raising these errors. 

Solution: Ensure that the datatype of parameter's values passed from Forms are the correct ones as specified in the "Datatype" property of the Reports User Parameters. Also, ensure that the length of the value passed from Forms is within the maximum "Width" specified in the Report User Parameters. 

Incomplete LOGIN string specified when connecting to Forms. 

This situation may be encountered when using the LOCAL (for Windows) and TWO_TASK (for Unix) environment variables in the default.env for Forms. 

In this case the following error may be encountered in the Reports Server Trace:

REP-501: Unable to connect to specified database.

Explanation: Using LOCAL or TWO_TASK environment variables allows Forms users to connect to the Forms application without specifying the Database (only username and password). In this situation, the login string that is being passed from Forms to Reports looks like this: SCOTT/TIGER@NULL. Reports cannot connect to the database using this login String and therefore this error is generated. 

Solution: The easiest solution is to be sure that the same variable is available also for Reports with the correct value: 
For Windows: Create a registry String Value with the value named LOCAL and having the Database SID as its value 
For Unix: Edit reports.sh and add the following line: 

TWO_TASK=your-database 

For more details check Note 382630.1 Rep-501 (Database Connection) On Report Calling Paramform and RUN_REPORT_OBJECT

Connection to a 11g Database with SEC_CASE_SENSITIVE_LOGON set 

In this case the following errors are encountered:

REP-501: Unable to connect to the specified database. 
FRM-41214: Unable to run report

Explanation: The database initialization parameter "SEC_CASE_SENSITIVE_LOGON" is set. This forces case sensitivity for the password used to logon to database and it is explained in the internal Bug 6655484 - UNABLE TO RUN REPORTS WITH 11G DB.
Solution: For the detailed solution check Note 469013.1 REP-501 when connecting to Database 11g using "RUN_REPORT_OBJECT"

 

Posted by Patrick Hamou on 2016:04:19 17:51:03